The Ultimate Guide to PHP Melody Updates

You’re here because you need help with an update problem or it’s your first time updating PHP Melody. Either way, the following guide should answer all your questions.

This document is divided into the following sections:

Overview

New features, improvements and bug fixes for PHP Melody come in the form of an update package. Applying the update packages is 100% optional but we do recommend you try to keep your PHP Melody website(s) up to date.

Updates bring changes to both the PHP Melody file structure as well as its MySQL database. That is why it’s crucial to always use the official update packages¬†to update your video site. We’ll show you how to correctly update your PHP Melody later in this guide.

In case you don’t have the time or desire to keep your PHP Melody up-to-date, we’re here to help. Our team can ensure your PHP Melody installation is always up-to-date by applying the new update packages. Please contact our support team to arrange for this service.

How do I know which PHP Melody version I’m using now?

Log into your website’s admin area and in the footer of all your pages you can find the PHP Melody version (as shown below):

powered

Note: In rare cases where the wrong patch/update files were applied in the past, an incorrect version might appear in the footer. Learn more about this in the ‘Troubleshooting’ section below.

How can I get the update packages?

UpdateYour customer account will give you access to both the full purchased product(s) as well as all the available update packages for each product.

The full product packages should only be used for new installations (never for updates).

To download the required update package(s), log into your Customer Account and browse to the ‘Download Updates‘ page.

It’s important to mention that you cannot and should never update your PHP Melody website(s) by applying the packages you can get from the ‘Download Products‘ page (i.e. the full product package).

To update your PHP Melody site correctly, always use the packages from the ‘Download Updates‘ page (i.e. the update package).

While it may sound obvious to you, we mention this because some customers have attempted to update their websites with the full package from the ‘Download Products‘ page only to find out that it ruins the site. That is because only the update packages include MySQL updating files.

Note: If you’ve applied the wrong update package or the full package, please see the ‘What can I do if I applied the wrong update or uploaded the full package by mistake?’ answer below.

How can I update my old PHP Melody installation?

Let’s begin by assuming you’re currently running PHP Melody v2.3 and need to update to the latest version which is v2.6.

Since between v2.3 and v2.6, we’ve released 5 other versions (v2.3.1, v2.4, v2.5, v2.5 [hotfix] and lastly v2.6), you will have to download all these update packages.
update-packs

 

 

 

 

You should end up with 5 zip packages saved locally. Begin the update process by unzipping the first update package (v2.3.1) and read the included Update Guide 2.3.1.pdf file. Note: each includes a update guide PDF.

Always read the Update Guide because each update includes important update instructions.

The update guides will advise you to only upload the update package after creating a backup of your current installation. Always backup your files and MySQL database before updating. Any problems can easily be solved by restoring the backup.

Once you’ve uploaded all the files and folders, log into your PHP Melody back-end site and follow the on-screen instructions to finish the update process. Logging into your administration area after uploading the update package is a mandatory step. It’s easy to overlook this step if you apply multiple updates.

Finally, if no update steps were skipped, your site will be updated to v2.3.1. You can now continue applying the next update package (v2.4). Repeat until you reach the latest version.

In summary, the key to a successful update is to: backup your existing files and MySQL database, read and follow the update instructions from the PDF, upload all the files and folders from the update package and update the MySQL database.

In case your site is using plugins/modules or custom themes, please see the ‘Troubleshooting’ section below. Any custom theme or plugin also has to be upgraded.

What can I do if I applied the wrong update or uploaded the full package by mistake?

Case 1: Uploading the wrong files without altering the MySQL database.

PHP Melody updates have safety-checks to ensure that you cannot accidentally apply the wrong update package. However, this covers the MySQL changes and it won’t prevent you from uploading the wrong files via FTP.

Let’s say you’re using PHP Melody v2.3 and, by mistake, uploaded the latest full package; v2.6. In this case, just restore the PHP Melody v2.3 files from the full package and overwrite the v2.6 files. In case you no longer have the v2.3 full package, please contact our support team and we will be happy to send you the required files.

After uploading the correct files, you can resume the update process by applying an update package.

Case 2: Applying both the wrong files and modifying or corrupting the MySQL database.

Without a backup there is little chance of fixing this problem by yourself because the damage is too extensive.

You shouldn’t worry because our team provides data recovery and general recovery services. We’ve successfully fixed numerous sites and recovered data in as fast as 24 hours for our customers.

We can help you fix corrupted MySQL tables, recover data from old PHP Melody installations and update your site in the process. Please get in touch with us if you’re looking to recover a crashed or wrongly updated site.

Frequent Asked Questions:

  1. I have an old PHP Melody site.  Can I skip straight to the latest update package?
    No. To correctly update PHP Melody you will have to apply each missing update; one after another. Read the “How can I update an old PHP Melody installation?” answer from above.
  2. Can I install the latest version and use my existing/old MySQL database?
    No. Because all updates include MySQL database changes your previous database will not have those changes. Having a mis-match between the files and the MySQL database version will cause problems. The PHP Melody files and the MySQL database should belong to the same version.
  3. I’ve been using a nulled copy but I want to update it. How can I get the missing update packages?
    Contact our team and describe your situation. We will send you the missing update packages. Be sure to mention which PHP Melody version you’re using at the moment.
  4. I’ve messed my website. Can you fix it for free?
    We’re glad to fix our bugs and problems free of charge. However, any intervention to fix problems caused by applying the wrong updates or incorrect product usage is a paid service.

Troubleshooting

I’ve updated my site exactly as you instructed but I cannot see the new features in the front-end.

In this case one of two things might have happened. Firstly, ensure the new feature(s) are not disabled by default (because some are). If your site uses a custom theme, make sure the theme is also up-to-date. To update your theme, simply download the latest theme version from your Customer Account and upload it to your site.

With each update, we’re also updating our available themes and plugins. Be sure to update your custom theme as well. Unlike PHP Melody, you can skip to the latest PHP Melody theme as long as the PHP Melody version and the theme version are the same/match.

I’m trying to change the settings form the back-end but the settings page doesn’t save them.

Such behavior indicates the MySQL database is not up to date. This is caused by either skipping updates or neglecting the last update step; updating the database. Since there is no general solution for this, contact our team. We can update your database for you (paid service).

My admin footer indicates I’m using the latest version but I don’t see the features or the latest theme.

There is a (slight) possibility that the version indicated is not true. This happens if someone manually updates the version number by hand or if the wrong update package was applied. If you’re unsure about this, contact our support team right away.

You may want to manually change the PHP Melody version so that you can apply the correct update package. To manually change the version number, use phpMyAdmin to manually edit the ‘pm_config’ table. Look for the ‘version’ entry and change the version as needed.

Warning: under normal circumstances you should never find yourself doing this. If you are, something has gone terribly wrong and perhaps the best idea would be to get in touch with our support team and determine what needs to be done next.
Never update the version number by hand unless you really know what you’re doing. We cannot take any responsibility for the problems this might cause.